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Note for mac-users of inkscape 
Copying and pasting in Inkscape creates pixelated images instead of copying 
the vector objects 
Starting with XQuartz 2.3.2, X11 has some functionality to exchange the content of the clipboard 
with OS X. But it currently does not know how to deal with vector images so it just captures the 
screen, i.e. creates a bitmap copy, and then pastes that. You need to deactivate this functionality 
in X11 preferences > Pasteboard: uncheck "Update Pasteboard when CLIPBOARD changes". 
However, this will also prevent copying text from any X11 application to Mac OS X ones. It will 
not prevent copying text from OS X to X11. 

2 Process for digitising your own map in Inkscape 
The process for digitising your own map is as follows: 

1. Setting up the document 
2. Digitising (bottom up) 
3. Legend and other map elements 

Below is a map I borrowed from a student, the area is Blue Lake at St Bathans. I will use this 
throughout the tutorial as an example. 

 

3 Setting up your document 
1. Open a blank inkscape document or use “blank_A2_template_with_layers.svg”. The template 

document already has a neatly organised layer structure. If you are creating your own the 
recommended layer structure is below: (bring up the layer panel by going to Layer>layers) 



 
 
Note: You can have additional layers if it helps you to better manage the document. 

2. The next step is to import the topo overlay, make topo_map the active layer by clicking on it. 
3. Go to File>Import and choose the topo map overlay you created. 
4. You should check that the topo overlay is the correct size. 
5. The next step is to import the scanned field map/s. Do the same thing as with the topo maps but 

make Scanned field maps the active layer. 
6. A window will pop up asking whether you want to embed or link your map. If you choose to link 

you must keep the scanned map in the same relative folder position to the inkscape document. 
Embedding will create a much larger file and may cause issues. 

Tip: You can check which layer an object is in by clicking on it and looking at the context sensitive 
help menu at the bottom of the inkscape window. 

7. Next we need to set the scanned map in the right place. Before you do this you should lock the 
topo_map layer (click on lock icon in layers panel). 

8. Line up part of the map with the topo map. Use cntrl click to scale without affecting aspect ratio. 
Keep moving it around and scaling it till it lines up properly with the topo overlay. 

4 Digitising your map overview 
At this point in time it’s a good idea to lock the scanned field map and hide the topo map (we won’t 
need to display the topo map again until later). Here is the general order you will do things in. 

1. Draw geological units first 
2. Draw the boundaries 
3. Digitising faults, anticlines etc. 
4. Plotting your foliation/bedding symbols 
5. Adding annotation elements  
6. Digitising the GVS etc. 
7. Bring it all together and Export as pdf or 300 ppi PNG 

TIP: If you do want single polygons for units and no overlap you can use Boolean operations to fix 
them 

5 Digitising your map: detailed instructions, tips and tricks 

5.1 Drawing geological units 
 



1. Make sure unit colours is the active layer. Set the opacity of this layer to about 50% 
2. What we want to do is draw from the lowest unit up (usually). Start by drawing a polygon 

covering the entire area of your basement lithology. Use the pen tool to draw. Straight line 
segments are the easiest to use and can be made by simply clicking along the line you want to 
digitise. If there are areas with a different lithology at the edge of the map then draw a line that 
overlaps the contact but does not go to the edge of the mapped area. 

  
Make this the colour of your basement lithology using the eyedropper tool to pick out a rough 
colour for the fill. 

3. For the next unit up draw exact contacts only where it meets the basement lithology or the edge 
of the mapped area. Wherever it meets units that are younger (or units you haven’t drawn yet) 
use a reasonable amount of overlap. Use the eyedropper to set the fill according to the unit you 
are digitising. Use a green stroke. 

If you continue in this way you should only have to draw a contact accurately once. If you’ve made 
any mistakes you can re-order polygons or move nodes to suite.  

4. Once you have all your units drawn you can tweak and fix the using the node tool.  
5. You can check what your map could look like by  

5.2 Drawing boundaries 
There are a couple of options for drawing unit boundaries:  

1. (the easy way) Draw the unit boundaries on as neatly as you can following where the unit 
colours meet. Provided you do this neatly it should be fine.. 

2. (advanced) Reusing your unit polygons as boundaries  –instructions below. 

5.2.1 Reusing your unit polygons as boundaries (advanced) 
1. Select all your unit polygons and copy them. 
2. Select the boundaries layer and go to Edit>Paste in place. This will put it in the exact spot as 

your units. 
3. Select all the unit polygons, remove the fill and give them a green stroke to make them easier to 

distinguish from the scanned map. 
4. You can remove all the overlapping paths that aren’t along a contact first by using the node tool. 

 
4.1. The easiest way to do this is to simply click on the segments you want to remove and then 

click on the delete segement between two non endpoint nodes. You may need to add or 
move nodes when you have line segments that you only want part of. 



 

5. Once you have only the contacts, you can break them at different points to make hard, dashed 
or dotted lines by simply changing the stroke style in the Fill and stroke panel, at this point you 
can also make them the correct stroke colour. See information on breaking a path in two below. 

 

5.2.2 Breaking paths 
If you have a path you want to break apart you must first break the path at the spot you want using 
the node tool. This creates a compound path (2 paths that are treated as one.) 

To make two completely separate paths you must select the path you want to divide and go to 
Path>Break Apart.  

5.3 Digitising Faults, folds etc. 
• You may want to add another separate layer for faults and anticlines etc. (or just use the unit 

boundaries layer). 
• Use the Symbol sheet as a guide or copy shapes from the symbol sheet. 
• For ticks on a line you can simply copy and paste (or duplicate cntrl +D) a triangle, rectangle or 

other shape, paste it along the line at regular intervals and the rotate it to match the line 
orientation. 

5.4 Symbols 
• Use the Symbol sheet as a guide or copy symbols directly from the symbol sheet. Draw a set of 

symbols that you are using off the side of the document so that you can copy and paste them 
when required.  

• Group different parts of a symbol together by selecting all the parts you want to group then go 
to Object>Group 

• For rotating symbols it’s generally easiest to do it manually, there is a way to rotate by a specific 
angle. 

 

5.4.1 Text in inkscape 

• You can change text properties such as font size etc. using the text and font panel  
Menu>Text>Text and Font. If you want to resize flowed text (text boxes) or type new text you 

can use the text tool .  
• You can resize anything including text and keep the aspect ratio by holding down Ctrl key. 

6 Editing the topo overlay in inkscape (Advanced) 
Since you have imported the topo overlay as a vector pdf into inkscape it is possible to edit it. You 
might want to edit it to move a label or something like that.  



The topo overlay comprises a series of nested groupings of objects. To move individual objects you 
will need to ungroup (right click >ungroup) the document until that object is by itself. Note that the 
nesting of objects is not necessarily in a way that is logical to humans. 

Be careful when editing the topo overlay. You can always re-import it though. 

7 Digitising GVS and other map elements 
The process for digitising a GVS or cross sections is pretty much the same as for the map. You might 
prefer to do your GVS and cross sections in a separate document and then import it at the end. 

You can use the eyedropper to get the exact colour you used for particular units. 

8 IMPORTANT: Map layout size  
You may need to adjust the page size to fit the map elements on comfortably. You should do so 
without changing the scale of the maps, GVS etc. There is no need to confine yourself to working on 
an A2 page or A1 page, it could be some intermediate size. Once you get beyond A1 maps become a 
bit unwieldy. 

9 Bring it all together and Export as pdf or 300 ppi PNG 
Via file>save as> and choosing pdf for file type. 
Or file>Export Bitmap> 

Use drawing area as page. 

Check your pdf after in adobe reader 

Included here is the feedback Luke gave for 344 Swinburn maps 2013 
Please read this so that you can improve upon the Swinburn map you made. 

10 Feedback for 344 Swinburn maps 2013 

10.1 Overall comments 
I am very impressed with the standard of the maps produced this year! This is one of the trickiest 
things to do in a graphics program like Inkscape due to the large work area and complexity of these 
documents with lots of layers and objects etc. You should feel confident now that you can make 
simpler graphics for figures in reports etc. that are high quality. I think everyone has also increased 
their understanding of how to represent things on a computer generally and in a graphics package 
specifically. This is a very useful tool that you will no doubt require further as you progress in 
Academia, Industry or elsewhere. 

10.2 Some things that could be improved upon 

10.2.1 Margins 



Most printers can’t print right up to the edges. Even if they could, you don’t want text going right up 
to the edges – it looks bad. Standard margins are 3-5mm. The printer I use is 3mm. If you are 
printing something where scale doesn’t matter you can use “fit to printable area”. I go into more 
detail on margins in this post on my blog: https://blogs.otago.ac.nz/si-geology/2012/01/10/margins-
for-printing/ 

10.2.2 Locality Maps 
The locality maps were generally not that good. Ideally a locality map should show where the region 
is in NZ with a box indicated. A regional map with the same spatial extent should then have another 
shape that matches the map you made (i.e. has a backwards z shape). 

You need to provide enough information (roads, place names, etc.) to locate the areas without 
overwhelming the reader with too much information (provision of detail). Refer to google maps at 
the scale you will make the map. What does google maps look like when the south island only is on 
the screen?(i.e. scale bar shows 200km) 

Your locality map should also look good. Google maps are adequate as far as provision of detail etc. , 
but they don’t look very good in print. Best to digitise them or use GIS data to create a locality map. 

A fair number of students must have copied a single locality map (shown above). The problem is that 
this map doesn’t look very good. To compound the issue it is a low resolution raster. You can’t read 
the text and it is too blocky anyway. You should check your entire document at 100% on the screen 
to make sure everything will reproduce adequately and make sure you output at 300ppi. This is one 
of the issues with producing large format documents on a small format low resolution screen! 

10.2.3 Page size, scale and detail 
A few people had the incorrect scale for their maps. The original document did have the correct 
scaIe at 1:10k. Some documents were A4, I have scaled these documents to fit A2 and they won’t be 
exactly 1:10k. 

Most of the class got the priorities wrong for their overall 
layout. I did recommend that people made the page larger to 
fit in GVS etc. but most people confined themselves to working 
on an A2 page. Some even re-scaled the map to fit. 

This is the wrong way to go about making a map. You should 
have just adjusted the page size to fit the map elements on 
comfortably without changing the scale of the maps, GVS etc. 
the page size doesn’t need to be A2 or A1 it could be some 
intermediate size. Once you get beyond A1 maps become a bit 
unwieldy. 

If you look at the QMAP series they come in a variety of sizes. 

10.2.4 Aspect ratio: Squished or flattened text, and maps 
Unless you are going for a specific effect there are a few things that you don’t want to change the 
aspect ratio of (ratio of width to height): photos, text or maps. 

https://blogs.otago.ac.nz/si-geology/2012/01/10/margins-for-printing/
https://blogs.otago.ac.nz/si-geology/2012/01/10/margins-for-printing/


 

10.2.5 Text in inkscape 

You can change text properties such as font size etc. using the text and font panel  Menu> 
Text>Text and Font. If you want to resize flowed text (text boxes) or type new text you can use the 

text tool .  

You can resize anything including text and keep the aspect ratio by holding down Ctrl key. 

10.2.6 Colour 
Avoid high saturation (deep) colours for blocks. It is sometimes difficult for the paper to take so 
much ink (gets wrinkled) and difficult to see dark text and lines on top. It is also unpleasing to the 
eye. 

10.2.7 Drawing order and overlapping graphics elements 
You should have had title, legend, GVS on top layer with white box behind. It looks bad to have lines 
(gridlines) going through the text. 

10.2.8 Datum and projection information 
There were quite a few variations on datum and projection information, with a few people that 
omitted it entirely. Here is an acceptable minimum amount of information to write: (NZGD2000 
Datum, New Zealand Transverse Mercator Projection). Both datum and projection must be specified. 
Refer to the notes you got in the GIS class. 

11 Further development of graphics skills 
I guess that people may have had a bit of trouble understanding why the software would behave in 
certain ways. For example why can’t you crop images in inkscape? Why does it take so long to do 
this or that? Why does text squish sometimes and flow other times? 

• There is a good reason why inkscape doesn’t crop images. 
• If it feels like something should be able to be done using a quicker method then chances are 

it can! 
• There are two ways to scale text: one reflows the text, the other squishes it.  

This is where further training comes in. Come along to one of my regular Tuesday 2pm or Thursday 
2pm workshops in the Paleo-sed Lab to get some more help.  
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